区块链学习记录-Hyperledger Fabric-安装Docker

作者: | 2018年1月18日

习惯了centos,所以选了centos7 64位作为测试机。

1.先安装Docker

1.1 先通过 uname -r 命令查看你当前的内核版本
Docker 要求 CentOS 系统的内核版本高于 3.10

1
uname -r

1.2 直接yum安装,我个人不喜欢折腾,先能用再说[貌似这个方法不好,版本好低,不建议使用了]

1
yum -y install docker

[推荐方法]

1
curl -sSL https://get.docker.com/ | sh

1.3 启动Docker

1
/bin/systemctl start docker.service

2.安装Docker-Compose(Docker-Compose是一个部署多个容器的简单但是非常必要的工具)
2.1 先安装pip,参考centos下最快速的安装pip方法
2.2 安装Docker-Compose

1
pip install docker-compose